|HOSTS(5)||File Formats Manual||HOSTS(5)|
hostsfile associates names and IP addresses. Each line has the following format:
Internet address Host or network name Aliases
Items are separated by any number of blanks and/or tab characters.
#’ indicates the beginning of a
comment; characters up to the end of the line are not interpreted by
routines which search the file.
The system configuration file
resolv.conf(5) controls where host
name information will be searched for. The mechanism provided permits the
administrator to describe the databases to search; the databases currently
known include DNS and the
When using a name server this file provides a backup when the name server is not running. For the name server, it is suggested that only a few addresses be included in this file. These include addresses for the local interfaces that ifconfig(8) needs at boot time and a few machines on the local network.
Internet addresses are specified using either dot notation (IPv4) or colon separated notation (IPv6) as described in inet_pton(3). Host names may contain any printable character other than a field delimiter, newline, or comment character.
hostsfile format appeared in 4.2BSD.
An official host database used to be maintained at the Network Information Control Center (NIC).
Up to OpenBSD 6.3, a separate file /etc/networks could be used to store network names.
Lines in /etc/hosts are limited to
BUFSIZ characters (currently 1024). Longer lines
will be ignored.
|May 28, 2019||HamBSD-current|